Warning: Using a password on the command line interface can be insecure.

在ubuntu服务器远程执行mssql备份的时候出现:Warning: Using a password on the command line interface can be insecure.

如下图:

mysql

这是由于新的MYSQL版本,在命令里输入密码信息,就会提示这些安全警告,导致无法执行.解决办法如下:
执行修改命令:

vim /etc/mysql/my.cnf

[mysqldump]

user=your_backup_user_name(你的mysql数据库名)

password=your_backup_password(你的mysql数据库密码)

修改完配置文件后,再执行mysqldump 的时候不需要再带上用户名和密码信息了。

发表评论

电子邮件地址不会被公开。 必填项已用*标注