标签归档:mysql

Warning: Using a password on the command line interface can be insecure.

在ubuntu服务器远程执行mssql备份的时候出现:Warning: Using a password on the command line interface can be insecure.

如下图:

mysql

这是由于新的MYSQL版本,在命令里输入密码信息,就会提示这些安全警告,导致无法执行.解决办法如下:
执行修改命令:

vim /etc/mysql/my.cnf

[mysqldump]

user=your_backup_user_name(你的mysql数据库名)

password=your_backup_password(你的mysql数据库密码)

修改完配置文件后,再执行mysqldump 的时候不需要再带上用户名和密码信息了。[……]

Read more

安装mysql5.0时出现:write configuration file

安装mysql5.0时出现:write configuration file .然后就一直停在这里不动了.

后来查资料发现可能是以下的问题导致的:

原因1:mysql的安装路径不能包含字符或者中文。
原因2:select a server type时选择了Server Machine项,write configuration file报错。
解决办法:修改安装路径重新安装。select a server type选择developer Machine项(开发测试类选用)

我这边导致的是原因2.不选这个就可以了~[……]

Read more

mysql5.0安装图解

很多朋友刚开始接触mysql数据库服务器,下面是网友整理的一篇mysql的安装教程,步骤明细也有详细的说明。

MySQL5.0版本的安装图解教程是给新手学习的,当前mysql5.0.96是最新的稳定版本。

mysql 下载地址 http://www.jb51.net/softs/2193.html

下面的是MySQL安装的图解,用的可执行文件安装的,详细说明了一下!打开下载的mysql安装文件mysql-5.0.27-win32.zip,双击解压缩,运行“setup.exe”,出现如下界面

mysql安装图文教程1

mysql安装图文教程1

mysql安装向导启动,按“Next”继续
mysql图文安装教程2

mysql图文安装教程2

选择安装类型,有“Typical(默认)”、“Complete(完全)”、“Custom(用户自定义)”三个选项,我们选择“Custom”,有更多的选项,也方便熟悉安装过程:
mysql图文安装教程3

mysql图文安装教程3

在“Developer Components(开发者部分)”上左键单击,选择“This feature, and all subfeatures, will be installed on local hard drive.”,即“此部分,及下属子部分内容,全部安装在本地硬盘上”。在上面的“MySQL Server(mysql服务器)”、“Client Programs(mysql客户端程序)”、“Documentation(文档)”也如此操作,以保证安装所有文件。点选“Change…”,手动指定安装目录。UTF8_E[……]

Read more

CodeSmith 连MySql(MySql 5.0.7)出错的解决办法

一直用CodeSmith,生成Oracle的代码, 最近要对MySQL做操作, 发现CodeSmith连接MySQL错误, 提示未能加载文件或程序集MySql.Data, Version=5.0.7.0, Culture=neutral,PublicKeyToken=c5687fc88969c44d或它的某一个依赖项。找到的程序集清单定义与程序集引用不匹配。 (异常来自HRESULT:0x80131040) 把MySQL.Data.dll,复制到Code


一直用CodeSmith,生成Oracle的代码, 最近要对MySQL做操作,

发现CodeSmith连接MySQL错误,

提示”未能加载文件或程序集“MySql.Data, Version=5.0.7.0, Culture=neutral,PublicKeyToken=c5687fc88969c44d”或它的某一个依赖项。找到的程序集清单定义与程序集引用不匹配。 (异常来自HRESULT:0x80131040)”
把MySQL.Data.dll,复制到CodeSmith下的Bin目录,再调用还是错误,百思不得其解,
后来看MySQL.Data.dll文件版本是5.2.1.0,比错误提示的大,看来要下一个5.0.7.0的试试,
下载地址是 http://ftp.ntu.edu.tw/pub/MySQL/Downloads/Connector-Net/mysql-connector-net-5.0.7-noinstall.zip ,
将其中的MySQL.Data.Dll文件重新复制到CodeSmith下的Bin目录,再配置测试,OK了.
看来CodeSmith将数据库程序调用写死了,应该设置成配置文件,让用户自己定义版本,这样才更灵活.[……]

Read more